Alexanders bild
Inlägg: 1257

lictor skrev:
Citerade mig själv från längre upp i tråden, se det för detaljer.


Ah, surt. Men, men, det mesta fungerar bra, och det lär bara bli bättre, dessutom är ju människorna på sajten det viktigaste. :) :beer:

KidCactuss bild
Inlägg: 720

Sebastian Magnusson skrev:
Återkom gärna om det funkar bättre nu, tror det kan vara fixat.

Jag kommer till sidan som inlägget finns på, men inte till inlägget. Detta i Safari i både OS X och iOS.

Denna länk:

http://www.skillpoint.se/node/107?page=5#comment-9991

skickar mig till:

http://www.skillpoint.se/forum/skillpointse/om-skillpoint/107?page=5

Hur kommer det sig att länken från Senaste inlägg inte har detta format från början, som inlägget i sig har i tråden?

http://www.skillpoint.se/forum/skillpointse/om-skillpoint/107?page=5#com...

Den länken funkar utmärkt.

Senast ändrad av KidCactus, 19 september, 2010 - 17:42.

Psykisk sjukmänniska

Sebastian Magnussons bild
Inlägg: 4776

KidCactus skrev:
Den länken funkar utmärkt.

Bägge länkarna är ju till samma ställe, bara att den senare är "prettyfied".

Men då förstår jag att du haft större problem än jag har haft, mitt är mer att den råkat välja fel sida ibland.

Prövade precis länkarna du postade i Safari och får samma här, men det funkar i alla mina andra browsers. Så det är Safari som vägrar ta med ankarhänvisningen (#) när det byter namn. Nå, då får jag se vad som går att göra åt det.

Definitionen av glädje är försvinnande plattformar.

Sebastian Magnussons bild
Inlägg: 4776

Tydligen en känd grej med Safari, att den kastar bort ankarfragment vid mod_rewrites. Vilken särdeles korkad funktion :p

Skall se om vi kan hämta ut snygga url-alias ur databasen istället då. Men det där borde ju vara en huvudvärk på många ställen känns det som, finns ju inte ett CMS i världen som inte använder mod_rewrite rejält för att få till snygga URL:er.

EDIT: oooh, url-alias var en helt annan tabell, vete sjutton om jag vill ha ytterligare en JOIN där. Safari-grejen bli inte fixad idag märker jag. Installera Chrome tills vidare ;)

Senast ändrad av Sebastian Magnusson, 19 september, 2010 - 18:01.

Definitionen av glädje är försvinnande plattformar.

TTV
TTVs bild
Inlägg: 1549

Hoppas buggen med pollen löser sig innan det börjar bli dags för mig att skapa GOTY-poll som jag gjorde på GP förra året. :ghost:

Sebastian Magnussons bild
Inlägg: 4776

Thörn skrev:
Hoppas buggen med pollen löser sig innan det börjar bli dags för mig att skapa GOTY-poll som jag gjorde på GP förra året

Påminn mig annars. Gärna en bit innan ;)

Definitionen av glädje är försvinnande plattformar.

TTV
TTVs bild
Inlägg: 1549

Sebastian Magnusson skrev:
Påminn mig annars. Gärna en bit innan

Räkna med det. :beer:

KidCactuss bild
Inlägg: 720

Sebastian Magnusson skrev:
Men det där borde ju vara en huvudvärk på många ställen känns det som, finns ju inte ett CMS i världen som inte använder mod_rewrite rejält för att få till snygga URL:er.

Jobbigt om det är Safari i sig som spökar. Men som sagt, det borde ju märkas på massor av ställen, men jag har konstigt nog aldrig stött på problemet tidigare. :tard:

Jag kör en pretty url-mod på WAG, där blir länkarna tillsnyggade före och inte efter att de klickats.

Psykisk sjukmänniska

Sebastian Magnussons bild
Inlägg: 4776

KidCactus skrev:
Jag kör en pretty url-mod på WAG, där blir länkarna tillsnyggade före och inte efter att de klickats.

Ja, så är det nog i många fall faktiskt. Kom på det också efter att jag postat.

Definitionen av glädje är försvinnande plattformar.

KidCactuss bild
Inlägg: 720

Sebastian Magnusson skrev:
Ja, så är det nog i många fall faktiskt. Kom på det också efter att jag postat.

Så är det ju i och för sig här också ser jag nu, på alla ställen förutom just Senaste inlägg. Kollar man inlägg från Citeringar, länkar till nyheter, bloggar, o.s.v., så är de tillsnyggade innan de är klickade.

Senast ändrad av KidCactus, 19 september, 2010 - 18:18.

Psykisk sjukmänniska

Sebastian Magnussons bild
Inlägg: 4776

KidCactus skrev:
Så är det ju i och för sig här också ser jag nu, på alla ställen förutom just Senaste inlägg. Kollar man inlägg från Citeringar, länkar till nyheter, bloggar, o.s.v., så är de tillsnyggade innan de är klickade.

Ja, de flesta ställen har det så. Finns några andra som går på /node/XXX - grejerna också. Länken till din egen profil i användarboxen, t.ex. Mer bestämt vissa av de delar jag kodat själv, som inte var inbyggda i Drupal.

Just "senaste inlägg" är dock EXTRA speciell även jämfört med användarboxen (där det mer handlar om lathet), iom att den kringgår hela CMS:et och hämtar data direkt från databasen.

Definitionen av glädje är försvinnande plattformar.

KidCactuss bild
Inlägg: 720

Sebastian Magnusson skrev:
iom att den kringgår hela CMS:et och hämtar data direkt från databasen.

Aha, ja då kanske det blir svårt att snygga till url:erna i den också, för jag antar att det är någon modul i CMS:et som gör det?

Psykisk sjukmänniska

Sebastian Magnussons bild
Inlägg: 4776

KidCactus skrev:
Aha, ja då kanske det blir svårt att snygga till url:erna i den också, för jag antar att det är någon modul i CMS:et som gör det?

Ja, det är inte omöjligt. Men inte helt trivialt heller, så inget som kommer fixas idag.

Aliasen ligger i en annan tabell än den vi hämtar från, och paras ihop via ID-grejer. Så behöver skrivas en JOIN-sats där nånstans. Avancerad SQL suger jag ganska mycket på, särskilt som vi redan har två andra JOIN i den databasfrågan

Definitionen av glädje är försvinnande plattformar.

KidCactuss bild
Inlägg: 720

Sebastian Magnusson skrev:
Tydligen en känd grej med Safari, att den kastar bort ankarfragment vid mod_rewrites.

Det här kanske kan hjälpa?

Redirecting Anchors

Description:
By default, redirecting to an HTML anchor doesn't work, because mod_rewrite escapes the # character, turning it into %23. This, in turn, breaks the redirection.

Solution:
Use the [NE] flag on the RewriteRule. NE stands for No Escape.

http://httpd.apache.org/docs/current/rewrite/rewrite_guide.html#redirect...

Senast ändrad av KidCactus, 19 september, 2010 - 18:32.

Psykisk sjukmänniska

Ollebros bild
Inlägg: 1061

En mysko grej om det ni talar om. i FF 4.0B6 så kan jag trycka på en kommentar någon lämnat i fältet till höger om allt. då hamnar jag på trådens första sida, där webbläsaren sedan laddas om och hamnar på sida två osv tills den hamnat på sidan som inlägget jag tryckte på är. inga problem ännu, men när vadsomhelstnätsomhelst tråden är 21490238 sidor lång kommer de bli jobbigt.

In the beginning the Universe was created.
This has made a lot of people very angry and been widely regarded as a bad move.

Mickemoss bild
Inlägg: 170

Reyqune skrev:
Testat ifall det uppstår i annan webbläsare?

Japp, det är bara i Safari det händer. I Firefox funkar det som det ska.
Jag har testat på flera datorer med samma Safari version och det är samma sak.
Konstigt nog blir det ännu smetigare om man scrollar samtidigt som sidan laddas.

"We've got cards and letters from lots of people that say iTunes is their favorite app on Windows. It's like giving a glass of ice water to somebody in hell" - Steve Jobs

Reyqunes bild
Inlägg: 979

Mickemos skrev:
Japp, det är bara i Safari det händer.

Testat en annan webkit-webbläsare? Exempelvis Google Chrome.

Sebastian Magnussons bild
Inlägg: 4776

Ollebro skrev:
En mysko grej om det ni talar om. i FF 4.0B6 så kan jag trycka på en kommentar någon lämnat i fältet till höger om allt. då hamnar jag på trådens första sida,

Laddade precis ned 40b6 till Mac, funkade utmärkt för mig. Prövat shift f5, så du inte har gammal kod liggande?

I annat fall får vi nog vänta till release candidate åtminstone, supporta beta-browsers är inte lönt när deras kod skiftar kontinuerligt.

Rymdyoghurt skrev:
Ta några skärmdumpar så ska vi nog kunna spåra fram den där gröten.

http://www.skillpoint.se/forum/skillpointse/om-skillpoint/107?page=5#com...

Nån aning om vad eller varför? I sure don't :p

Mickemos skrev:
ag har testat på flera datorer med samma Safari version och det är samma sak.

Bara av ren nyfikenhet, är alla på samma nätverk? Funderar på om det är nåt i din routerbrandvägg som bråkar med nåt i vår css-fil?

Definitionen av glädje är försvinnande plattformar.

Rymdyoghurts bild
Inlägg: 246

Mickemos skrev:
Såhär skojigt kan det se ut ibland:

Wicked! Den verkar ju blanda grafik från sidfoten, hoppa ur page-inner-div, dublera element och göra andra mystiska tolkningar alldeles godtycklig. Jag har testat både i en äldre version av Safari och OSX, samt en likadan uppsättning som din på min nya Macbook Pro hemma. Aldrig råkat ut för något liknande, eller haft något problem över huvudtaget. Är det bara Skillpoint som jävlas för dig eller har du märkt av liknande krupp på andra sidor? Känns som det kan ligga något i det Sebastian sa, att den inte laddar in CSS:en korrekt.

Men tittar man på din första skärmdump blir jag dock mycket fundersam. Du har någon form av grafikfel/artifakter på headerbilden, strax ovanför menyn. Att en feltolkning av CSS skulle leda till dylika fel på bilder känns inte troligt. Vi ska vara uppriktiga och säga att vår CSS inte är helt problemfri när man kör den mot W3Cs validering, men den innehåller heller inte den typen av missar som kan skapa dylika problem. Uppstod det knarkiga i headerbilden just i skärmdumpen du tog, eller ser det ut så i skarpt läge också?

Don't piss in my ear and tell me it's raining.

Mickemoss bild
Inlägg: 170

Rymdyoghurt skrev:
Är det bara Skillpoint som jävlas för dig eller har du märkt av liknande krupp på andra sidor?

Bara Skillpoint, konstigt nog.

Rymdyoghurt skrev:
eller ser det ut så i skarpt läge också?

Det är inte skärmdumpen som spökar. Det ser ut så.

Sebastian Magnusson skrev:
Bara av ren nyfikenhet, är alla på samma nätverk?

Hm... Jo det stämmer ju faktiskt. Jag tar och testar på annat nätverk senare idag.

Senast ändrad av Mickemos, 21 september, 2010 - 14:25.

"We've got cards and letters from lots of people that say iTunes is their favorite app on Windows. It's like giving a glass of ice water to somebody in hell" - Steve Jobs

Reyqunes bild
Inlägg: 979

Har servern problem? Tar väldigt lång tid att ladda hemsidan just nu.

Sebastian Magnussons bild
Inlägg: 4776

Reyqune skrev:
Har servern problem?

Nä.

Reyqune skrev:
Tar väldigt lång tid att ladda hemsidan just nu.

Går kvickt för mig nu. Men kanske är överspelat nu?

Skall ta mig en titt i loggarna under helgen iaf, får se om man ser något...

Definitionen av glädje är försvinnande plattformar.

Ollebros bild
Inlägg: 1061

Sebastian Magnusson skrev:
I annat fall får vi nog vänta till release candidate åtminstone, supporta beta-browsers är inte lönt när deras kod skiftar kontinuerligt.

det händer så till och från nu så det är ju klart bättre.väldigt underlig bugg bara :p

In the beginning the Universe was created.
This has made a lot of people very angry and been widely regarded as a bad move.

Reyqunes bild
Inlägg: 979

Sebastian Magnusson skrev:
Går kvickt för mig nu. Men kanske är överspelat nu?

Tar cirka 5-8sekunder att byta sida. :tard:

Senast ändrad av Reyqune, 25 september, 2010 - 09:11.

KidCactuss bild
Inlägg: 720

Reyqune skrev:
Tar cirka 5-8sekunder att byta sida.

Så är det för mig med, det går riktigt segt.

Att posta detta inlägg och sedan få sidan att laddas om med inlägget tog ca 20 sekunder.

Senast ändrad av KidCactus, 25 september, 2010 - 10:24.

Psykisk sjukmänniska

kuwabatakes bild
Inlägg: 95

KidCactus skrev:
Så är det för mig med, det går riktigt segt.

Reyqune skrev:
Tar cirka 5-8sekunder att byta sida

Same same här.
För min del så segar det ett tag utan att något händer, men sen när det väl uppdaterar/ändrar sida så går det fort.

en apa!
vill du smaka?
18446744073709551616

Sebastian Magnussons bild
Inlägg: 4776

Looking into it...

Definitionen av glädje är försvinnande plattformar.

Alexanders bild
Inlägg: 1257

Samma här. Använder Safari i Snow Leopard.

Sebastian Magnussons bild
Inlägg: 4776

kuwabatake skrev:
För min del så segar det ett tag utan att något händer, men sen när det väl uppdaterar/ändrar sida så går det fort.

Aaa, precis, samma här.

Pingen hit är bra, devel rapporterar att alla databashämtningar går skitfort, att ladda ned stora filer/bilder går kvickt, inga fel rapporterade i loggarna. Så det är inte bandbredd, vår kod eller databasen, utan antagligen minne eller cpu.

Iom att vi ligger på shared hosting är det säkert nåt annat fucko som gör nåt fel och äter alla våra cykler :p

Får undersöka mer imorgon om det inte löst sig av sig själv tills dess (vilket jag misstänker att det kommer göra).

KidCactus skrev:
Så är det för mig med

Du som kan mycket om interwebben, håller du med om min analys?

Definitionen av glädje är försvinnande plattformar.

KidCactuss bild
Inlägg: 720

Sebastian Magnusson skrev:
Du som kan mycket om interwebben, håller du med om min analys?

Jag håller med, det är ju definitivt inte generellt långsam hastighet vare sig mot servern eller databasen som gör att det går segt. När väl servern svarar så laddas ju allt ner direkt:

Hur ser det ut när du kör till exempel ftp mot servern, är det likadant då?

Psykisk sjukmänniska

Copyright Skillpoint™     Chefredaktör: Sebastian Magnusson
Inget material på sajten får kopieras utan tillstånd.